KonifarPod

GooglePlayServicesがgradleでsyncできない時の対処法

   

Pocket

GooglePlayServiceをgradleで使う場合、以下のように書けばサクッと使えるようになります。

dependencies {
    compile 'com.google.android.gms:play-services:4.2.42'
}

 

が、could not be foundとか言われてエラーになることがあります。僕はエラーになりました。

これはすごく単純で、Android SDKに必要なライブラリを落としていないせいです。

Android SDK Managerを開いて、『Google Repository』がインストールされているか確認して、インストールされていなければしましょう。

Googleplaylib1

 

インストールしたら問題なくなるはずですが、もしそれでも変わらなかったらAndroid StudioのSDKの場所を確認した方がよいかもしれません。

File > Project Structure を開いて、左メニューのSDK Locationから確認できます。

Googleplaylib2

Pocket

 - 未分類 , ,